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Introduction 

Dreamweaver is Macromedia's entry into the very competitive web page/site editing 
software marketplace.  Similar to products such as Microsoft's FrontPage and Netscape's 
Composer, Dreamweaver relies on a WYSIWYG interface that makes it easy to design web 
pages by drawing them the way you want them to look.  It is a cross-platform product available 
for both Windows and Macintosh computers.  At educational discount, Dreamweaver is less than 
$100.  You can buy it locally through University Bookstore.  You can also buy Dreamweaver 
bundled with other Macromedia web products such as Fireworks and Flash. 

Dreamweaver has won kudos from web design professionals for its features and power.  
Although it relies on easy-to-use WYSIWYG editing, the HTML code that results from the 
editing process in Dreamweaver, unlike many of its competitors, is very "clean" – that is, it lacks 
unnecessary HTML tags that other editors often create.  Dreamweaver even sports tools to clean 
up the HTML from other applications, particularly the often messy code produced by Microsoft 
Word.  In addition, for HTML users, Dreamweaver allows simultaneous viewing of both the 
WYSIWYG and HTML environments with full editing capability in either one.  Dreamweaver 
also supports a number of features that allow web designers to create interactive, not just static, 
web pages.  Finally, Dreamweaver is extensible.  This means, for example, that although 
Dreamweaver itself does not provide direct support for placing Quicktime movies on a web 
page, a third-party extension that provides such support can be added to the program to enhance 
its capabilities.  For more information about the program, look in the online help, reference 
books, or on the Macromedia web site (http://www.macromedia.com). 

 

Getting Started with Dreamweaver 
 When you launch Dreamweaver, you will see something like the screen shown below.  In 
addition to the work area (the document window), there are three main floating palettes that 
contain most of the tools you will need to build web pages: the objects palette, property 
inspector, and launcher. 
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If all three palettes are not visible, go to the Window menu and select the first three 
options to make them visible.  The palettes float, which means that can be positioned anywhere 
on the screen.  To move a palette, simply click on the title bar (displayed in blue) and drag it to 
the desired position.  This makes it easy to place the palettes so that they don't interfere with your 
work area (although, typical of Macromedia products, you will find that you must do a lot of 
moving of things, closing/opening, and switching between palettes as you work). 

The document window shows you the current web page approximately as it will appear in 
a browser.  The Property Inspector displays the properties for any currently selected object on 
your working page; properties vary based on the object selected (i.e. text properties differ from 
image properties).  The Launcher lets you quickly open various other windows, such as the 
HTML code window, the Site window, the Timeline, and the Library.  Finally, the Objects 
palette gives you quick access to the various objects you might want to use when creating a web 
page.  The Objects palette is actually several palettes in one -- common tools, characters, forms, 
frames, head, and invisibles.  By clicking on the drop down box under the title bar, you can 
switch between these options.  The common tools are shown here. 

 
 The other Objects palettes include: Characters Objects (special symbols such copyright 
symbol, fancy quotes), Forms Objects (form tools such as text fields, buttons), Frames Objects 
(various frame types), Head Objects (objects for the page head such as keywords), and Invisibles 
Objects (named anchors, comments, non-breaking blank spaces, scripts).  If you add an 
extension to Dreamweaver, in most cases, an additional option will become available through 
one of the Objects palettes to let you insert the extension object. 

 Before you first begin to work on a web page, you should define site information.  This is 
how Dreamweaver keeps track of everything related to your project.  From the Site menu, select 
New Site.  You will see the following dialog box. 
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Enter a name for Site Name (e.g., EDCI 101 Course Site).  Select a Local Root Folder path 
where you will store your files (click the folder icon to browse for the desired location).  NOTE: 
we recommend you keep all of your website files in a single folder that you create on your hard 
disk or on a floppy or zip disk dedicated to the website alone; this will avoid later problems and 
confusion.  If you are working on your hard disk, create a new folder for your website first and 
then select it as the Local Root Folder.  When you have defined the name and path, click OK.  
You’ll be asked if you want to create a cache for the site; click Create.  A new window, the Site 
window, will appear.  Initially, it will probably be empty, but as you create new files they will 
appear in this window.  It will show you all the “stuff” in your website.  For now, close the Site 
window.  You can open it again when you need it by going to the Window menu and selecting 
Site Files or by clicking the Site button on the Launcher palette. 

 

Adding Text 
 Let's get started!  First, we’ll learn how to add the basic features of any web page such as 
text, images, and hyperlinks.  Then, we’ll create a template that you can use to create the pages 
in a typical course website.  Text is a key element of most web pages, so we'll begin by adding a 
little text.  To add text, just click on the page and start typing.  Type "My Own Web Page" 
(without the quotes), and hit the Return/Enter key.   

 



 

 

Your text should appear in normal size type in the upper left corner of the page.  Let's 
turn this into a heading.  Use your mouse to highlight the text just as you would in any word 
processor.  Notice that the Property Inspector window shows you various text options.  From the 
Format drop-down box on the Property Inspector, pick Heading 1.  Then, click the center 
alignment icon on the Property Inspector palette.  Your heading should now be large and 
centered on the page. 

 Now, move your cursor down to the second line and enter some normal text.  If you hit 
Return/Enter after you typed the heading text but before you formatted it, the text will revert 
back to standard left-aligned paragraph text.  If not, just highlight the text, and select the 
paragraph and left-aligned options from Property Inspector palette.  To add a list, just click the 
bulleted (unordered) list icon or the numbered (ordered) list icon on the Property Inspector.  
Your result might look something like this. 

 
 

Defining Page Properties and Saving a Page 
 To define the basic properties of your page, from the Modify menu select Page 
Properties.  You'll see the dialog box shown below.  Enter a title for your page.  You can also 
select options such as background colors and link colors.  Click OK when you are finished. 

 



 

 

Before continuing, save your page.  From the File menu, select Save As, and give your page a 
name.  Click Save to save it.  By default, the page is saved to the site location that you defined. 

 

Adding Pictures 
 Recall that all web browsers support two basic graphics formats, GIF and JPG (or JPEG).  
GIF, Graphic Interchange Format, is a 256-color format originally used on CompuServe that is 
good for simple graphics with limited colors such as clip art.  One type of GIF, an animated GIF, 
uses a sequence of still GIF images packaged into a single file to create a simple form of 
animation on web pages.  JPG, Joint Photographic Experts Group, is a true-color (up to 16 
million colors) format that works best for photographic images.  You can create your own GIF or 
JPG images using a digital camera or scanner or by converting existing images in other formats.  
Many sites on the Internet have pictures that you can download by right-clicking on them.  
Remember: assume all images on the Internet are copyrighted.  We recommend you either ask 
permission or use only images from reputable sites that are identified as freely usable. 

To insert an image, click on the image button on the Common Objects palette or go to the 
Insert menu and choose Image.  You will see a standard file load dialog box.  Locate an image to 
add to your page.  Select the image and click OK to add it to your page. 

 
IMPORTANT: unlike a Word document, image files are not stored inside the web page when 
you save the page.  All that is maintained is a link to the location of the picture file.  As a result, 
picture files that are not saved along with web pages are likely to become “lost” resulting in 
missing images when the page is placed on a web server.  To help avoid this problem, 
Dreamweaver warns you whenever you insert an image that isn’t stored in the site folder. 

 



 

 

To insure that all images are stored with other website files, click Yes when this dialog box 
appears.  Dreamweaver will make a copy of the image file and put it in your site folder. 

Notice that when the image is selected, the Property Inspector palette displays image 
options.  Various picture alignment options are available.  Click the alignment drop-down box, 
and select Left.  Notice that a little yellow marker appear next to the image; this marker, which is 
invisible when the page is displayed in a browser, simply denotes that special formatting has 
been applied to the image.  To size the image, use the handles (little squares around the edges of 
the box); hold down the shift key while dragging the corner handle to maintain the aspect ratio 
(that is, to keep things in proportion). 

 

Adding Links 
 Web pages usually rely on links to other web pages.  Let's add a link here.  First, type the 
text that will be your link.  (You can also use an image as a link simply by selecting it and 
following the same process.)  In this case, we'll create a link to Yahoo, the popular web portal.  
Type the text "Go to Yahoo".  Highlight the text.  Click the center alignment icon on the 
Property Inspector palette to center the text.  Now, you have two options for how to create the 
link.  Type the URL directly in the Link box of the Property Inspector palette, or from the 
Modify menu choose Make Link and enter the URL in the URL box.  The URL for the Yahoo 
site is http://www.yahoo.com.  Your text will be displayed as a link.  Your page should now look 
something like this. 

 
To actually test your link, you need to preview your page in a browser.  From the File 

menu, choose Preview in Browser, and select a browser.  This launches the browser and displays 
your page.  When Dreamweaver is installed, one browser is normally set as the default, but you 
can easily access both Netscape Navigator and Internet Explorer, if they are both on your 
computer.  This makes it easy to check your website’s compatibility with both popular browsers.  
Pages do vary from one to the other.  You can try out your page to see how it looks and works.   

 



 

 

You now understand the basics of working with Dreamweaver.  Next, we’re going to create a 
template for a course website.  First, erase everything that you’ve done so far.  (Don’t worry – 
we’re going to make something better.)  From the Edit menu, choose Select All and then just hit 
the Delete key on your keyboard. 

 

Adding Template Images 
The first thing we’re going to do is add a couple of images to create a consistent “look 

and feel” for our web pages.  If you have not yet done so, copy the files “backgnd.gif” and 
“heading.gif” to your site folder or disk.  These files were created in advance using a graphics 
program.  You could make something similar yourself. 

First, let’s add a background image.  From the Modify menu select Page Properties.  
Click the Browse button next to Background Image.  Select “backgnd.gif” and click Select.  
Click OK to close the Page Properties dialog box.  This inserts a background image that will 
create the visual appearance of a navigational sidebar on the edge of the page. 

Now, we’ll add an image that will serve as a header on the page.  Your cursor should be 
in the upper left corner of the page.  From the Insert menu choose Image (or click the Image icon 
on the Common Objects Palette).  Locate and select “heading.gif” and click Select to insert it.  
Click on the image to select it.  In the Alt box on the Property Inspector, type: “EDCI 101 
Heading”.  This creates what is called an Alt tag, a textual label that will appear if the browser 
doesn’t load the image or if a sight-impaired individual uses a screen reader.  You should always 
create text labels for images that you use on web pages.   

Your page should now look something like this. 

 
Using a Table for Page Layout 
 Web pages cannot easily be laid out as precisely as a Word document.  One convenient 
way to control the layout of web page information that works even with older browsers is to use 
tables.  We’re going to use a table to position the elements of our page. 

 First, click behind the EDCI 101 heading picture, and hit the Enter/Return key to move 
the cursor down to the next line.  To insert a table, from the Insert menu choose Table (or click 
the Table icon on the Common Objects Palette).  A table dialog will appear.  Select 2 rows, 2 



 

 

columns, and a border of 0 (ignore the other options for now).  A table will be inserted on the 
page.  Click on the line that divides column one from column two.  Your cursor will turn into a 
two-headed arrow.  Drag to the left until the columns roughly line up with the background 
image.  Your page should now look something like this. 

 
Now, we will add content to the table. 

 

Building Template Content 
Navigation Links 

 First, let’s create a series of navigation links in the first cell of the table.  Click inside the 
first cell (the upper left).  Enter the following text labels, hitting the Enter key between each one: 
“Home”, “Syllabus”, “Course Links”, “Contact Info”, and “Purdue SOE”. 

 Next, let’s make each text label into a link.  Initially, most of the pages to which we will 
link will not exist.  But, we will be creating these pages shortly.  Highlight “Home” and then 
enter “index.htm” in the Link box on the Property Inspector.  Highlight “Syllabus” and enter 
“syllabus.htm” in the Link box on the Property Inspector.  Highlight “Course Links” and enter 
“links.htm” in the Link box on the Property Inspector.  Highlight “Contact Info” and enter 
“contact.htm” in the Link box on the Property Inspector.  For our last item, we’ll create a link to 
an existing page.  Highlight “Purdue SOE” and enter “http://www.soe.purdue.edu” in the Link 
box on the Property Inspector.  

Now, we need to make certain that these links will appear in the upper part of the table 
cell regardless of how the table grows and expands.  To do this, click on an empty space 
anywhere inside the first cell.  In the Property Inspector, choose Top from the Vert (vertical 
alignment) drop-down box.  Your page should now look something like the figure below. 



 

 

 
Credits 

 Now, let’s add our credits information.  Click in the lower right cell of the table.  Enter 
the following information:  “Page created by: John Doe. Last updated: today’s date.”  Substitute 
your name for “John Doe” and the actual date for “today’s date.”  Highlight the text.  Center and 
italicize it.  From the font size drop-down box on the toolbar, scroll down until you find “-1”, 
and select it.  This makes the font one size smaller than the default. 

 Let’s make your name an e-mail link.  To do this, highlight your name in the credits area, 
and then in the Link box in the Property Inspector enter “mailto:” followed by your e-mail 
address (without the quotes and leaving no spaces). 

Content 
 Finally, let’s add some placeholders for the content.  Click in the upper right-hand cell of 
the table.  Enter “Heading” and hit the Enter key.  Highlight “Heading” and make it into a first 
level heading by selecting Heading 1 from the format drop-down box on the Property Inspector.  
Position your cursor on the next line and enter “Content”.  Click anywhere in an empty spot of 
the upper right-hand cell.  Select Top from the Vert (vertical alignment) drop-down box on the 
Property Inspector.  Our template is now complete and should look something like this. 



 

 

 
 Save the template.  From the File menu choose Save As (do not choose Save As 
Template – we’ll consider that option at another time).  Name the file “template.htm” and save it 
to your site.  We will now use the template file to create copies of each of our course web pages.   

Re-saving the Template as Separate Pages 
Let’s start with the home page.  First, we need a visual cue about what page we’re on.  

Highlight the “Home” link.  Erase what is in the Link box on the Property Inspector and hit 
Enter/Return.  “Home” is no longer a link, just normal text.  The change in appearance will let us 
know that’s the page we’re on.  From the Modify menu, choose Page Properties.  In the Title 
box, give the page a title such as “EDCI 101 Home Page” (substituting your own course).  From 
the File menu, choose Save As.  Enter “index.htm” as the file name, and click Save to save the 
file.  From the File menu, choose Close.  When prompted with the question, “Do you want to 
quit Dreamweaver?” click No.  This closes the current file without ending our session. 

Now, we’ll repeat the process for our other pages.  First, re-open “template.htm”.  From 
the File menu choose Open, and select “template.htm”.  Highlight the “Syllabus” link.  Then, 
erase what is in the Link box on the Property Inspector and hit Enter/Return.  “Syllabus” is no 
longer a link.  From the Modify menu, choose Page Properties.  In the Title box, give the page a 
title such as “EDCI 101 Syllabus” (substituting your own course).  From the File menu, choose 
Save As.  Enter “syllabus.htm” as the name, and click Save to save the file.  From the File menu, 
choose Close.  When prompted with the question, “Do you want to quit Dreamweaver?” click 
No. 

From the File menu choose Open, and select “template.htm”.  Highlight the “Course 
Links” link.  Erase what is in the Link box on the Property Inspector and hit Enter/Return.  From 
the Modify menu, choose Page Properties.  In the Title box, give the page a title such as “EDCI 
101 Course Links”.  From the File menu, choose Save As.  Enter “links.htm” as the name, and 
click Save to save the file.  From the File menu, choose Close.  When prompted with the 
question, “Do you want to quit Dreamweaver?” click No. 

From the File menu choose Open, and select “template.htm”.  Highlight the “Contact 
Info” link.  Erase what is in the Link box on the Property Inspector and hit Enter/Return.  From 



 

 

the Modify menu, choose Page Properties.  In the Title box, give the page a title such as “EDCI 
101 Instructor Contact Info”.  From the File menu, choose Save As.  Enter “contact.htm” as the 
name, and click Save to save the file.  From the File menu, choose Close.  When prompted with 
the question, “Do you want to quit Dreamweaver?” click No. 

We are done.  Let’s try out our navigation links to see how the pages will work.  From 
the File menu choose Open, and select “index.htm”.  This is the main or home page.  From the 
File menu, select Preview in Browser to test the page.  Click the “Syllabus” link.  You should 
now see the Syllabus page.  Try the other links to see if they bring up the appropriate pages. 

What you now have is the skeleton of a web site but without flesh on the bones.  To add 
your own content, simply open the desired page and substitute a title and actual content for the 
placeholders that we put there.  You can add text, images, and links; in short, you can put 
whatever you want to share on your pages.  For example, open your Syllabus page 
(syllabus.htm).  Replace the word heading with “EDCI 101 Syllabus” or whatever is appropriate 
for your own course.  Then, add syllabus information for the content.  On your Course Links 
page (links.htm), put links to external websites that would be of interest to students in your 
course.  On the Contact Info page (contact.htm), put your office number, phone, and e-mail 
address so that students can get in touch with you.  Continue this process to flesh out a course 
website.  When you are done, you’ll have a fully functional website complete with your own 
content and navigation links from one page to another.   

 

Putting Your Website on a Web Server 
Once you have completed your website on your local computer, the final step is to place 

it onto a web server so that it will be accessible to everyone on the Internet.  This requires that 
you define the server site and copy your files to that site.  From the Site menu, select Define 
Sites.  A dialog box will appear showing all of your defined sites.  Select your site from the list 
on the left (there will only be one site listed if this is your first use of Dreamweaver), and click 
the Edit button.  The Site Definition dialog that you saw at the beginning will again appear. 

 
From the list on the left, click on Web Server Info.  You will see a single drop-down list 

on the right.  To connect from your office, select Local/Network (from home, you would need to 
select FTP) from the drop-down list.  You should now see something like the dialog shown 
below. 



 

 

 
Click on the folder icon next to Remote Folder to browse to locate your website folder.  

Most SOE users have a web folder in their personal space on the departmental server and are 
automatically linked to the departmental server, which mounts as a network drive on one’s office 
computer.  (If you don’t have a website space set up, contact the SOE Technical Support staff.)  
Locate your web folder and select it.  After closing out the dialog boxes, the remote site will 
appear on the left side of the Site Window and the local site will appear on the right. 

Now, uploading files to the server is a simple matter.  From the Site Window, simply 
click the Put button.  You will be prompted if you wanted to put the entire site; click OK to copy 
the site from your local computer to the server.  To copy files from the server to your local site, 
simple click Get.  Once both local and remote sites are in use, if you make changes to something, 
simply select Synchronize from the Site menu in the Site Window.  You can choose to 
synchronize selected files or the whole site, and you can determine the direction of the updating 
(e.g., Put Newer Files to Remote copies updated files from your local site to the server). 

 

This completes our basic introduction to Dreamweaver.  We have only introduced the 
fundamentals of web page design using this popular authoring tool, but it is more than enough 
for you to get started.  Put information about your courses onto the web.  Student will appreciate 
your effort and the convenience of access to information.  To make it manageable, start small 
and build up your course sites over time.  In no time, you’ll have a great web presence! 
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