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Introduction 

You've already learned the basics of Dreamweaver, Macromedia's popular webpage 
editing package.  At the basic level, there isn't much difference between Dreamweaver and 
competing products such as Microsoft's FrontPage and Netscape's Composer.  It is 
Dreamweaver's more advanced features that have made it an especially popular alternative 
among website designers.  In this handout, we'll explore some of those more advanced features 
for formatting and adding interactivity to webpages.  Note: these advanced features require 
newer browsers, Netscape Navigator 4 or higher or Internet Explorer 4 or higher.  For more 
information about the program, look in the online help, reference books, or on the Macromedia 
web site (http://www.macromedia.com). 

Before starting your Dreamweaver project, create a folder, on your computer's hard drive 
or removable media such as a floppy or Zip disk, where you will keep all of your website files.  
After launching Dreamweaver, define a new site.  From the Site menu, select New Site.  Enter a 
name for Site Name, and select your folder by browsing to define the Local Root Folder path.  
When you have defined the name and path, click OK.  You’ll be asked if you want to create a 
cache for the site; click Create.  A new window, the Site window, will appear.  Initially, it will 
probably be empty, but as you create new files they will appear in this window.  It will show you 
all the “stuff” in your website.  For now, close the Site window.  You can open it again when you 
need it by going to the Window menu and selecting Site Files or by clicking the Site button on 
the Launcher palette. 

We will pick up where the previous Dreamweaver workshop left off – with a course 
template page.  If you already have a template page saved, skip ahead to Using Styles to Format 
Webpages on page 5.  Otherwise, go through the steps below to create a template page. 

 

Adding Template Images 
The first thing we’re going to do is add a couple of images to create a consistent “look 

and feel” for our web pages.  If you have not yet done so, copy the files “backgnd.gif” and 
“heading.gif” to your site folder or disk.  These files were created in advance using Macromedia 
Fireworks, a graphics program.  You could make something similar yourself. 

First, let’s add a background image.  From the Modify menu select Page Properties.  
Click the Browse button next to Background Image.  Select “backgnd.gif” and click Select.  
Click OK to close the Page Properties dialog box.  This inserts a background image that will 
create the visual appearance of a navigational sidebar on the edge of the page. 

Now, we’ll add an image that will serve as a header on the page.  Your cursor should be 
in the upper left corner of the page.  From the Insert menu choose Image (or click the Image icon 
on the Common Objects Palette).  Locate and select “heading.gif” and click Select to insert it.  
Click on the image to select it.  In the Alt box on the Property Inspector, type: “EDCI 101 
Heading”.  This creates what is called an Alt tag, a textual label that will appear if the browser 
doesn’t load the image or if a sight-impaired individual uses a screen reader.  You should always 
create text labels for images that you use on web pages.   
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Your page should now look something like this. 

 
 
Using a Table for Page Layout 
 Web pages cannot easily be laid out as precisely as a Word document.  One convenient 
way to control the layout of web page information that works even with older browsers is to use 
tables.  We’re going to use a table to position the elements of our page. 

 First, click behind the EDCI 101 heading picture, and hit the Enter/Return key to move 
the cursor down to the next line.  To insert a table, from the Insert menu choose Table (or click 
the Table icon on the Common Objects Palette).  A table dialog will appear.  Select 2 rows, 2 
columns, Cell Padding 0, Cell Spacing 0, Border 0, and a Width of 100%.  A table will be 
inserted on the page.  Click on the line that divides column one from column two.  Your cursor 
will turn into a two-headed arrow.  Drag to the left until the columns roughly line up with the 
background image.  Your page should now look something like this. 
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Now, we will add content to the table. 

 

Building Template Content 
Navigation Links 

 First, let’s create a series of navigation links in the first cell of the table.  Click inside the 
first cell (the upper left).  Enter the following text labels, hitting the Enter key between each one: 
“Home”, “Syllabus”, “Course Links”, “Contact Info”, and “Purdue SOE”. 

 Next, let’s make each text label into a link.  Initially, most of the pages to which we will 
link will not exist.  But, we will be creating these pages shortly.  Highlight “Home” and then 
enter “index.htm” in the Link box on the Property Inspector.  Highlight “Syllabus” and enter 
“syllabus.htm” in the Link box on the Property Inspector.  Highlight “Course Links” and enter 
“links.htm” in the Link box on the Property Inspector.  Highlight “Contact Info” and enter 
“contact.htm” in the Link box on the Property Inspector.  For our last item, we’ll create a link to 
an existing page.  Highlight “Purdue SOE” and enter “http://www.soe.purdue.edu” in the Link 
box on the Property Inspector.  

Now, we need to make certain that these links will appear in the upper part of the table 
cell regardless of how the table grows and expands.  To do this, click on an empty space 
anywhere inside the first cell.  In the Property Inspector, choose Top from the Vert (vertical 
alignment) drop-down box.  Your page should now look something like the figure below. 

 
Credits 

 Now, let’s add our credits information.  Click in the lower right cell of the table.  Enter 
the following information:  “Page created by: John Doe. Last updated: today’s date.”  Substitute 
your name for “John Doe” and the actual date for “today’s date.”  Highlight the text.  Center and 
italicize it.  From the font size drop-down box on the toolbar, scroll down until you find “-1”, 
and select it.  This makes the font one size smaller than the default. 
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 Let’s make your name an e-mail link.  To do this, highlight your name in the credits area, 
and then in the Link box in the Property Inspector enter “mailto:” followed by your e-mail 
address (without the quotes and leaving no spaces). 

Content 
 Finally, let’s add some placeholders for the content.  Click in the upper right-hand cell of 
the table.  Enter “Heading” and hit the Enter key.  Highlight “Heading” and make it into a first 
level heading by selecting Heading 1 from the format drop-down box on the Property Inspector.  
Position your cursor on the next line and enter “Content”.  Click anywhere in an empty spot of 
the upper right-hand cell.  Select Top from the Vert (vertical alignment) drop-down box on the 
Property Inspector.  Our template is now complete and should look something like this. 

 
 Save the template.  From the File menu choose Save As (do not choose Save As 
Template – we’ll consider that option at another time).  Name the file “template.htm” and save it 
to your site. 

 

Using Styles to Format a Webpage 
You've learned a little about using basic HTML to format webpages.  You can apply 

formatting elements like italics or boldface to text.  You can enlarge text by making it a heading.  
You can use tables to lay out the elements on a webpage.  These techniques work with all 
browsers, even older ones.  

With newer browsers, Netscape Navigator 4 or Internet Explorer 4 or greater, website 
designers can make use of a relatively new feature of HTML called cascading style sheets (CSS).  
CSS style sheets provide a way to control the appearance of a range of text in a webpage or 
multiple webpages.  They define a set of formatting attributes, identified by a name or by an 
HTML tag, that control such things as text font, size, and positioning.  This is similar to the use 
of style sheets in word processors like Microsoft Word.  An advantage of the use of style sheets 
over HTML is that when a style sheet is updated, all of the webpages that use that style become 
automatically updated as well.  Although they provide greater power than plain HTML, keep in 
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mind that older browsers cannot use styles, and even newer browsers may not fully implement, 
or may implement differently, certain style attributes.  Let’s see what these can do by defining a 
style sheet for the course webpage template we just created. 

Defining a Style 
To create a new style, from the Text menu, choose CSS Styles and then Edit Style Sheet.  

You’ll see a dialog box like the following. 

 
Click the New button to start defining a new style.  You will see a dialog with three possible 
options: 

 
The first option, Make Custom Style (class), defines a style that is applied through a class 

attribute to a block of text such as a paragraph or bulleted list.  The second option, Redefine 
HTML tag, allows you to redefine the formatting when you apply a particular HTML tag such as 
H1 (first level heading).  [CAUTION: when you redefine an HTML tag, the results are applied 
to all instances of that tag in any pages that use that style.  This may create undesirable results.]  
The third option, Use CSS Selector, allows you to define the formatting for particular 
combinations of tags (e.g., how a heading appears when inside a table).  Let’s create a couple of 
custom styles that we will apply to portions of our template. 

Heading Style 

Let’s start by making a Custom Style for our headings.  Select the first radio button.  In 
the name field, enter a new name.  Let’s call this “.heading101”.  [Note: custom style names 
always begin with a period; if you don’t type it yourself, Dreamweaver will automatically add 
it.]  Then, click OK.  The Style definition dialog box will open as shown below. 



More About Dreamweaver  7 

 

 
There are a number of options that can be set to define a style.  These, shown in the Category list 
on the left, include: 

• Type – allows you to set the font, font size, style, etc. of the text. 

• Background – lets you set background attributes such as of a table 

• Block – lets you determine word and letter spacing as well as alignment 

• Box – allows control over size of a page element such as an image 

• Border – sets border attributes of a page element such as table or image 

• List – sets list attributes 

• Positioning – controls position of the element 

• Extensions – affects some special characteristics such as mouse cursor 
In this case, just set the text attributes as shown in the figure below. 
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Click OK when you’ve set the attributes.  Then, click Done.  Your custom style is now defined. 

Content Style 

Let’s do another Custom Style for our content.  From the Text menu, choose CSS Styles 
and then Edit Style Sheet.  Click the New button to start defining a new style.  Select the first 
radio button.  In the name field, enter “.content101”.  Now, set up the text definitions as shown 
below. 

 
Again, to complete the operation click OK, then click Done.  We now have two custom styles 
defined. 

Applying Styles 
Now, let’s apply our custom styles to the appropriate parts of our template.  To see the 

available CSS styles, from the Window menu choose CSS Styles.  You’ll see a dialog box like 
the one shown below. 

 
On the template we created, select Heading.  Click heading101 from the CSS Styles 

dialog box.  The style will be applied to the heading.  Now select Content.  Click content101 
from the CSS Styles dialog box.  That style is now applied to the content.  The template page 
will now look like this. 
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The actual style definition is placed inside the webpage as part of the HEAD section of 

the document.  You can inspect it by viewing the HTML source; click the HTML source button 
(<>) in the lower right of the Dreamweaver window.  The use of styles makes it easy to 
predefine consistent looks for webpages and then simply apply them as needed to different page 
elements.  [CAUTION: applying more than one style to a page element can result in style 
conflicts that can produce unexpected effects.  Avoid applying multiple styles.] 

Saving as a Style Sheet 
To keep a set of styles so that they can be applied to other documents, you can save the 

styles as an external CSS style sheet.  To do this, from the File menu choose Export then Export 
CSS Styles.  A file save dialog will appear as shown below. 

 
Give the style sheet a name and click Save.   
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To retrieve an external CSS style sheet for use in a new document, from the Text menu 
select CSS styles.  You’ll see the usual dialog box. 

 
Click Link.  Then, browse to locate the file contains the desired styles.  Then, the styles will 
become available via the CSS Styles window. 

 

Creating a Dreamweaver Template 
We created a simple webpage template above.  However, what we created is not a true 

Dreamweaver template but simply a webpage that can be easily reproduced to generate other like 
webpages.  Dreamweaver gives you the capability to create a genuine template that can be used 
to stamp out many pages with a consistent look.  You can make a template from scratch, working 
with a blank document, or you can use an existing webpage to create a template.  Since we 
already have a webpage to work with, let’s use it to create a Dreamweaver template. 

Make sure you have template.htm open in Dreamweaver.  From the File menu, choose 
Save as Template.  You’ll see the following dialog box. 

 
Click the Save button to save it.  It will be save as template.dwt (where the extension dwt 
denotes Dreamweaver template.) 
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Making Parts of the Template Editable 
By default, when you create a template, all of the parts of it are locked, that is uneditable.  

Since you do want to be able to make changes to many parts of a page as you create new pages 
from the template, you first must define the parts of the template that are editable.  In the case of 
our page, there are three main parts that will change: the heading, the content, and the date.  
(We’ll ignore for now the links, which we might want to appear differently in some cases.) 

Let’s do the date first.  First, on the template, highlight the date.  Next, from the Modify 
menu, choose Templates then New Editable Region.  You will see the following dialog box. 

 
Enter “date” as the name and click OK.  A placeholder {date}will appear where the date once 
was. 

Repeat the process for Heading and Content.  Select Heading then define a New Editable 
Region called “heading”.  Select Content and define a New Editable Region called “content.”  
Your template should now look like this. 

 
From the File menu, choose Save to re-save the template with the changes.  A dialog box 

will warn you that changes have been made and ask if you want to update all pages.  Since we 
haven’t applied the template to any pages yet, click No.  In the future, if you make changes to the 
template, Dreamweaver can automatically update all pages that use it. 
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Creating Pages from a Template 
To create a new webpage from the template, from the File menu choose New from 

Template.  From the dialog box (shown below), click on the name of the desired template and 
click Select. 

 
You will see the new page with the editable and non-editable regions color coded.   

 
Simply select the editable elements to change them.  When you have made your updates, from 
the File menu choose Save As, and save the page with the desired name.  Repeat our earlier 
exercise by using the template to create index.htm, syllabus.htm, links.htm, and contact.htm.  

Dreamweaver templates provide a short-cut for producing multiple webpages with a 
consistent look.  [Note: because we defined certain styles earlier, they apply to the pages created 
from this template.  However you cannot apply new styles to a page created from a template, 
because the head of the document, where styles are stored, is locked.] 

If you ever have reason to remove a template from a webpage, you can do it by selecting 
Modify, Templates, Detach from Template. 
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Using Behaviors 
 One last feature of Dreamweaver that we'll examine is behaviors.  Behaviors allow for 
interactivity on a web page; they allow the browser to carry out some action in response to an 
event (e.g., a mouse click) that occurs within the browser environment.  Behaviors rely on 
Javascript, the scripting languagethat is built into browsers and supports browser actions that do 
not rely on processing from the server.  The good news is that Dreamweaver automatically writes 
the Javascript code necessary to carry out these actions.  You don’t need to know how to 
program to make it work. 

 Let's create an example that is very applicable to education.  Let's see how to put a simple 
multiple choice quiz question on a web page, where feedback can automatically be displayed on 
the page in response to the user's choices.  The action of the user clicking on a choice invokes the 
action, namely the display of feedback.  This example relies on layers, containers for HTML 
content that are supported by version 4.0 and later browsers.  As with the previous content in this 
handout, this example will not work with older browsers that do not support layers. 

 To begin, let's create a new web page for the quiz question.  From the File menu, select 
New.  Set the Page Properties from the Modify menu.  Then, create a short multiple choice quiz 
just using ordinary text.  (You might want to pick a larger than normal size for good visibility.)  
An example is shown below. 

 
In order to associate an action with each answer, the answers must be turned into links 

(i.e. something the user can click).  But, in this case, we do not want the links to go to another 
page.  We want each answer to link locally on this page.  The way to do this is to create what is 
called a named anchor, a spot that allows for internal linking on this page.  However, our named 
anchor will not have an actual name.  It will be a blank anchor.  This is simply a device to let us 
make a link that we can use to invoke an action.   

Highlight the first answer.  In the Link box of the Properties palette, enter a pound sign 
(#).  That’s it.  That creates a link to nowhere.  Repeat the process for each of the four answers.  
You’ll end up with a page like the figure below. 
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Adding a Layer 

Next, we need someplace to hold the feedback that we will provide to the user.  We will 
use something called a layer.  Layers, a relatively recent addition to HTML, are invisible 
containers that can hold any of the elements of a webpage.  They have the advantage of being 
controllable in a way that pages themselves are not.  You can finely position layers, make them 
visible or invisible, and even use them to create animations without having to have Flash or 
another add-in.  [CAUTION: layers are not always accurately rendered by browsers, especially 
Netscape Navigator.  Avoid relying heavily on layers for placement of page elements.] 

From the Common Objects palette, select the layer icon or choose Layer from the Insert 
menu.  Your cursor will change into the layer drawing tool.  Using the tool, draw a box beneath 
the last answer in your quiz.  The result should look something like this. 
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If you need to adjust the location of the layer, click and drag using the little square handle 
that sticks up from the upper left corner of the box.  If you need to resize the layer, click on the 
line that makes up the box and handles will appear.  Use those to resize the layer.  In this case, 
we're only going to have a little text as feedback, so this size layer should adequate. 

While the layer is selected, set the properties in the Properties Inspector.  If the layer is 
not selected, click on it or click on the yellow symbol that appears at the top of the page 
indicating that a layer exists.  The default name of the first layer created is "Layer 1."  Change 
the name to "feedback."  That's the only change we'll make to the properties. 

 
Adding Behaviors 

Now, let's make stuff happen!  Click anywhere on the first answer link.  From the 
Window menu choose Behaviors.  The Behaviors dialog box will open as shown below.   

 
Initially, there are no behaviors associated with this link.  To create one, click the plus 

sign in the dialog box.  A list of menu options will appear.  Select Set Text then Set Text of 
Layer.  The following dialog box will appear. 

 
Your layer will appear in the top (you have a choice if there is more than one layer), and you can 
enter the desired feedback in the bottom part of the box.  Here, we should say something to the 
effect that answer A is incorrect.  (The correct answer in this example is C.)  So, type whatever 
you would like to appear as feedback and click OK.   
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The behaviors dialog box will now look like this. 

 
Notice that in the Events column, it shows onMouseOver and in the Actions column it shows Set 
Text of Layer.  The action is fine, but the event is not what we want.  The onMouseOver event is 
triggered when the mouse passes over the link.  In other words, the user would see this just by 
passing the mouse over the answer.  We want the user to have to click on the answer.  So, click 
directly on the event (onMouseOver).  An arrow denoting a drop-down menu will appear.  Click 
on the drop-down arrow, and from the list select onClick.  That's the event that we want.  Now, 
the first option is done. 

 Repeat the process for each of the remaining answers in the multiple choice question.  
Click on the answer link, select the behavior, enter appropriate feedback, and change the event to 
onClick.  When you are finished with all of the answers, close the Behaviors window.  Save your 
work, and then do Preview in Browser to test how it actually works.  Here are examples of 
wrong and right answers with corresponding feedback. 

        
To format the feedback, for example to make it larger or in a color, you can embed 

HTML tags in the text that you enter in the Set Text of Layer dialog box.  (For example, use  
<H3>That is correct.</H3>  to make somewhat larger feedback.)  This is a simple but powerful 
way to create true interactivity on your web pages. 
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