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Introduction 

FrontPage is Microsoft’s entry into the very competitive web page creation software 
marketplace.  Similar to products such as Netscape's Composer and Macromedia’s 
Dreamweaver, FrontPage relies on a WYSIWYG interface that makes it easy to design web 
pages by constructing them on screen the way you want them to look.  In addition, because it is a 
Microsoft product, it is available to Purdue faculty and staff through the Microsoft Campus 
Agreement.  The program’s interface, menus, and toolbars should be familiar to users of other 
Microsoft programs such as Word and Excel.  Frontpage is only available for Windows users; 
although a Macintosh version was produced initially, it has not been updated. 

This handout introduces FrontPage within the context of creating a template for web 
pages that could be used to support a course website.  For more information about the program, 
look in the online help, reference books, or on the Microsoft web site.  There is an online tutorial 
available from Microsoft at: 
          http://msdn.microsoft.com/workshop/languages/fp/2000/tutorial2000/default.asp 

 

Getting Started with FrontPage 
 Launch FrontPage like any other Windows program.  You should see a screen like the 
figure shown below.  (If you don’t, go to the File menu and choose New then Page.)  In addition 
to the work area where the page is developed, you can see the usual Microsoft menus and 
toolbars.  There is also a Views Bar on the left; we’ll concentrate on the Page view only (the 
other views support site management features).  The Page Views Tabs in the lower left are used 
to shift your views of the page.  The Estimated Download Time in the lower right projects how 
long the page will take to load on a 28.8 K modem connection.  This is a useful tool for gauging 
if your page is getting too large for typical off-campus users. 
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 Before you begin to work on your first web page, set the basic options for the program.  
From the Tools menu choose Page Options.  Click on the Compatibility tab.  From the Browsers 
drop-down box, choose “Both Internet and Explorer and Navigator.”  From the Browser versions 
drop-down box, choose “3.0 browsers and later.”  (See the figure below.)  These choices cause 
some of the “fancy” features of FrontPage to be unavailable, but they insure that your web pages 
can be viewed using just about any web browser.  We recommend you stick with these options at 
least until you become more comfortable with web authoring. 

 
 Let's get started building a web page.  First, we’ll learn how to add the basic features of 
any web page such as text, images, and hyperlinks.  Then, we’ll create a template that you can 
use to create the pages in a typical course website. 

 

Adding Text 
Of course, text is a key element of most web pages, so we'll begin by adding a little text.  

To add text, just click on the page and start typing.  Type “My Own Web Page” (without the 
quotes), and hit the Return/Enter key.  Your text should appear in normal size type in the upper 
left corner of the page.  Let's turn this into a heading.  Use your mouse to highlight the text just 
as you would in any word processor.  From the Style drop down box (the left-most drop-down 
box on the toolbar), select Heading 1.  [The next drop-down box controls the font.  In most cases, 
it is best to leave the font choice on “(default font)”, which means that whatever font is set as the 
browser’s default will be displayed.  If you do decide to select a particular font, use only 
commonly available fonts (e.g., Arial, Times New Roman).  If you select an unusual font and 
someone attempts to view your page on a computer that does not have that font installed, another 
font will be substituted, which can lead to unexpected results.  The third drop-down box controls 
font size.  In most cases, leave this selection “Normal”, which again relies on the browser’s 
settings to determine size.]  Click the center alignment icon on the toolbar to center your 
heading.  Your page should now look like the figure below. 
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 Now, move your cursor down to the second line and enter some normal text.  Hit Enter if 
you want to start a new paragraph.  To add a list, just click the bulleted (unordered) list icon on 
the toolbar or the numbered (ordered) list icon on the toolbar.  Your result might look something 
like this. 
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Saving and Naming Your Page 
 Let’s save the page now so that you see how to save and title your page.  From the File 
menu, select Save As.  You will see a standard file save dialog box as shown below.  (NOTE: 
we recommend you keep all of your website files in a single folder on your hard disk or on a 
floppy or zip disk dedicated to the website alone; this will avoid later problems and confusion.) 

 
Navigate to where you wish to save your file.  Notice what is shown next to Page Title at 

the bottom; by default, FrontPage uses whatever you put in the first line of your page.  Click the 
Change button to change the page title.  In the dialog box that appears, enter “John Doe’s Home 
Page” (substituting your own name) as the new title, and click OK.  Let’s also change the file 
name (which is not normally the same as the title).  In the File Name box, type “index.htm”.  [On 
most web servers, index.htm is a special file name that denotes the main or start-up page.  Either 
.htm or .html can be used as the extension for web pages.  NOTE: many web servers distinguish 
between upper and lower case letters.  We recommend you consistently use all lower case letters 
to avoid confusion and possible problems.]  Now, save your file by clicking the Save button. 

 

Adding Pictures 
 In FrontPage, you can add clip art or pictures from a file.  First, let’s see how to add 
traditional Microsoft clip art, something that web page editors other than FrontPage cannot easily 
do.  Click below the text on your page.  (You may have to hit Enter to move the cursor down 
below your text.)  From the Insert menu, choose Picture then Clip Art.  Click the Academic 
button and then choose the first image.  (Images available will vary depending on what is 
installed on your computer.)  Your page should now look something like the figure below. 
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 Click directly on the image to select it.  Handles (little squares around the edges) will 
appear that allow you to resize the image.  You will probably want to make the image smaller.  
To set the properties for the image, right-click the image and choose Picture Properties from the 
pop-up menu.  Click the Appearance tab to select alignment and other properties.  We will also 
need to change the type of file to make it web compatible.  Click the General tab. 

Web browsers support two basic graphics formats, GIF and JPG.  GIF, Graphic 
Interchange Format, is a 256-color format originally used on CompuServe that is good for simple 
graphics with limited colors such as clip art.  (One type of GIF, an animated GIF, uses a 
sequence of still GIF images packaged into a single file to create a simple form of animation on 
web pages.)  JPG, Joint Photographic Experts Group, is a true-color (up to 16 million colors) 
format that works best for photographic images.  The Microsoft clip art format is neither GIF nor 
JPG, so it won’t work as is with most web browsers.  To make the image web compatible, we 
need to convert it.  To do this, simply click the GIF radio button.  Since clip art is composed of 
limited colors, GIF is the best choice. 

IMPORTANT: unlike a Word document, image files are not stored inside the web page 
when you save the page.  All that is maintained is a link to the location of the picture file.  As a 
result, picture files that are not saved along with web pages are likely to become “lost” resulting 
in missing images when the page is placed on a web server.  We recommend you keep copies of 
all pictures in the same folder as your web pages.  If you do this, you will be much less likely to 
“lose” your picture files.  To do this now, click Save to re-save your file.  A dialog box will 
appear that prompts you to save the embedded clip art image.  Change the file name to 
something meaningful (e.g., books.gif), and be sure to save it in the same location as your web 
page. 
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If you want to insert an image from a file, from the Insert menu choose Picture and then 
From File.  Navigate to the desired file and click OK to insert it.  Remember, only GIF or JPG 
images are universally recognized.  Existing images in other formats should be converted to 
these formats.  Many sites on the Internet have pictures that you can download by right-clicking 
on them.  Remember: assume all images on the Internet are copyrighted.  We recommend you 
either ask permission or use only images from reputable sites that are identified as freely usable. 

 

Adding Links 
 Web pages also rely on links to other web pages.  Let's add a link here.  First, type the 
text that will be your link.  (You can also use an image as a link simply by selecting it and 
following the same process.)  In this case, we'll create a link next to the image of the books to the 
Library of Congress website.  Type the text "Library of Congress", and highlight the text.  Now, 
click the hyperlink icon (which resembles a globe with a chain link underneath it) on the toolbar.  
You’ll see the hyperlink dialog box.  Notice that “http://” is already started in the URL box.  
Enter the address of the Library of Congress website, which is “lcweb.loc.gov” after the “http://” 
in the URL box and click OK. 

 
 

Viewing the Page 
To actually test your link, you need to preview your page.  Click the Preview tab in the 

bottom left corner of the page.  (This invokes Internet Explorer within FrontPage.)  Test your 
link!  It should go to the Library of Congress website.  Since there is no way to go back with 
Preview mode, simply click on the Normal tab to return to your working page. 

While we’re checking out views, let’s take a look at the other tab.  Click the HTML tab.  
This shows you the actual HTML code that underlies your page.  If you know HTML, you can 
make changes or additions in this view that will be reflected in the other views.  Click the 
Normal tab to go back to the normal view.



Introduction to FrontPage  8 

 

 You now understand the basics of working with FrontPage.  Next, we’re going to create a 
template for a course website.  First, erase everything that you’ve done so far.  (Don’t worry – 
we’re going to make something better.)  From the Edit menu, choose Select All and then just hit 
the Delete key on your keyboard. 

 

Adding Template Images 
The first thing we’re going to do is add a couple of images to create a consistent “look 

and feel” for our web pages.  If you have not yet done so, copy the files “backgnd.gif” and 
“heading.gif” to the folder or floppy disk where you are storing your web page files.  These files 
were created in advance using a graphics program.  You could make something similar yourself. 

First, let’s add a background image.  Right-click on any blank part of the page, and select 
Page Properties from the pop-up menu.  Select the Background tab.  Click the Background 
picture checkbox.  In the name box, enter “backgnd.gif” or click the Browse button to locate the 
file on your disk.  This inserts a background image that will create the visual appearance of a 
navigational sidebar on the edge of the page. 

Now, we’ll add an image that will serve as a header on the page.  Your cursor should be 
in the upper left corner of the page.  From the Insert menu choose Picture and From File.  Locate 
and select “heading.gif” and click OK to insert it.  Right click on the picture, and select Picture 
Properties from the pop-up menu.  Under Alternative representations, in the Text box type: 
“EDCI 101 Heading” and click OK.  This creates what is called an Alt tag, a textual label that 
will appear if the browser doesn’t load the image or if a sight-impaired individual uses a screen 
reader.  You should always create text labels for images that you use on web pages.   

Your page should now look like the figure below. 
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Using a Table for Page Layout 
 Web pages cannot easily be laid out as precisely as a Word document.  One convenient 
way to control the layout of web page information that works even with older browser versions is 
to use tables.  We’re going to use a table to position the elements of our page. 

 First, click behind the EDCI 101 heading picture, and hit the Enter key to move the 
cursor down to the next line.  To insert a table, click on the Table icon on the toolbar and pull 
down with your mouse to create a 2 x 2 table.  The table will appear on your page.  Click on the 
line that divides column one from column two.  Your cursor will turn into a two-headed arrow.  
Drag to the left until the columns roughly line up with the background image.  Now, right-click 
anywhere within the table and select Table Properties from the pop-up menu.  Change the 
Borders Size box to 0.  This will make the table borders invisible in browsers.  Your page should 
now look something like this. 

 
Now, we will add content to the table. 

 

Building Template Content 
Navigation Links 

 First, let’s create a series of navigation links in the first cell of the table.  Click inside the 
first cell (the upper left).  Enter the following text labels, hitting the Enter key between each one: 
“Home”, “Syllabus”, “Course Links”, “Contact Info”, and “Purdue SOE”. 

 Next, let’s make each text label into a link.  Initially, most of the pages to which we will 
link will not exist.  But, we will be creating these pages shortly.  Highlight “Home”, and then 
click the Hyperlink icon on the toolbar.  In the URL box, erase the “http://” that is already there.  
We’re creating what is called a relative link (a link to a file in the same folder), so we don’t want 
the “http://” prefix (which denotes an absolute web address).  In the name box, enter “index.htm” 
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and click OK.  Highlight “Syllabus”, click the Hyperlink icon, erase “http://”, and enter 
“syllabus.htm”.  Highlight “Course Links”, click the Hyperlink icon, erase “http://”, and enter 
“links.htm”.  Highlight “Contact Info”, click the Hyperlink icon, erase “http://”, and enter 
“contact.htm”.  

For our last item, we’ll create a link to an existing page.  Highlight “Purdue SOE”, and 
click the Hyperlink icon.  This time, keep the “http://” and add “www.soe.purdue.edu”.  

Now, we need to make certain that these links will appear in the upper part of the table 
cell regardless of how the table grows and expands.  To do this, right-click anywhere inside the 
first cell.  From the pop-up menu, choose Cell Properties.  From the Vertical Alignment drop-
down box, choose Top.  Your page should now look something like the figure below. 

 
Credits 

 Now, let’s add our credits information.  Click in the lower right cell of the table.  Enter 
the following information:  “Page created by: John Doe. Last updated: today’s date.”  Substitute 
your name for “John Doe” and the actual date for “today’s date.”  Highlight the text.  Center and 
italicize it.  From the font size drop-down box on the toolbar, choose 10 pt. 

 Let’s make your name an e-mail link.  To do this, highlight your name in the credits area, 
and then click the Hyperlink icon on the toolbar.  In the URL box, erase the “http://” and replace 
it with “mailto:” followed by (leaving no spaces) your e-mail address. 

Content 
 Finally, let’s add some placeholders for the content.  Click in the upper right-hand cell of 
the table.  Enter “Heading” and hit the Enter key.  Highlight “Heading” and make it into a first 
level heading by selecting Heading 1 from the style drop-down box on the toolbar.  Position your 
cursor on the next line and enter “Content”.  Right-click on the cell, and select Cell Properties 
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from the pop-up menu.  Select Top from the Vertical Alignment drop-down box.  Our template is 
now complete and should look something like this. 

 
 Save the template.  From the File menu choose Save As.  Change the page title to “Web 
Page Template.”  Name the file “template.htm” and save it to the location where you are keeping 
your files.  We will now use the template file to create copies of each of our course web pages.   

Re-saving the Template as Separate Pages 
Let’s start with the home page.  First, we need a visual cue about what page we’re on.  

Highlight the “Home” link.  Then, click on the Hyperlink icon.  Erase what is in the URL box, 
and click OK.  “Home” is no longer a link, just normal text.  The change in appearance will let 
us know that’s the page we’re on.  From the File menu, choose Save As.  Click the Change 
button to give the page a title, such as “EDCI 101 Home Page” (substituting your own course).  
Enter “index.htm” as the file name, and click OK to save the file.  (Since we created a file with 
this name earlier, you’ll need to click OK when asked if you want to overwrite the existing file.)  
From the File menu, choose Close to close the current file without ending our FrontPage session. 

Now, we’ll repeat the process for our other pages.  First, re-open “template.htm”.  From 
the File menu choose Open, and select “template.htm”.  Highlight the “Syllabus” link.  Then, 
click on the Hyperlink icon.  Erase what is in the URL box, and click OK.  “Syllabus” is no 
longer a link.  From the File menu, choose Save As.  Click the Change button to give the page a 
title, such as “EDCI 101 Syllabus”.  Enter “syllabus.htm” as the name, and click OK to save the 
file.  From the File menu, choose Close to close the current file without ending the FrontPage 
session. 

From the File menu choose Open, and select “template.htm”.  Highlight the “Course 
Links” link.  Then, click on the Hyperlink icon.  Erase what is in the URL box, and click OK.  
From the File menu, choose Save As.  Click the Change button to give the page a title, such as 



Introduction to FrontPage  12 

 

“EDCI 101 Course Links”.  Enter “links.htm” as the name, and click OK to save the file.  From 
the File menu, choose Close to close the current file without ending the FrontPage session. 

From the File menu choose Open, and select “template.htm”.  Highlight the “Contact 
Info” link.  Then, click on the Hyperlink icon.  Erase what is in the URL box, and click OK.  
From the File menu, choose Save As.  Click the Change button to give the page a title, such as 
“EDCI 101 Instructor Contact Info”.  Enter “contact.htm” as the name, and click OK to save the 
file.  From the File menu, choose Close to close the current file. 

 We are done.  Let’s try out our navigations links to see how the pages will work.  From 
the File menu choose Open, and select “index.htm”.  This is the main or home page.  Click the 
Preview tab at the bottom of the window to test the page.  Click the “Syllabus” link.  You should 
now see the Syllabus page.  Try the other links to see if they bring up the appropriate pages.  
When you have finished, click the Normal tab to return to normal view of the “index.htm” file. 

 

What you now have is the skeleton of a web site but without flesh on the bones.  To add 
your own content, simply open the desired page and substitute a title and actual content for the 
placeholders that we put there.  You can add text, images, and links; in short, you can put 
whatever you want to share on your pages.  For example, open your Syllabus page 
(syllabus.htm).  Replace the word heading with “EDCI 101 Syllabus” or whatever is appropriate 
for your own course.  Then, add syllabus information for the content.  On your Course Links 
page (links.htm), put links to external websites that would be of interest to students in your 
course.  On the Contact Info page (contact.htm), put office number, phone, and e-mail address so 
that students can get in touch with you.  Continue this process to flesh out a course website.  
When you are done, you’ll have a fully functional website complete with your own content and 
navigation links from one page to another.   

Remember, save all of your work, including picture files, to one location.  When you 
have finished, you can upload all of your files to your departmental web server.  For most SOE 
users, this is simply a matter of copying the files to your web folder in your personal space on 
your departmental server.  Most users are automatically linked to their departmental server, 
which mounts as a network drive on one’s office computer.  Alternatively, you can access your 
personal web space via FTP; if you need this type of access, please contact the SOE Technical 
Support staff so that they can assist you with the necessary arrangements.  Once uploaded onto 
an SOE server, you can edit your files directly using FrontPage, and changes will be immediately 
reflected on the web. 

This completes our basic introduction to FrontPage.  We have only introduced the 
fundamentals of web page design using this popular authoring tool, but it is more than enough 
for you to get started.  Put information about your courses onto the web.  Student will appreciate 
your effort and the convenience of access to information.  To make it manageable, start small 
and build up your course sites over time.  In no time, you’ll have a great web presence! 
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